앨리스의 토끼

javahawk.egloos.com

포토로그 방명록


최근 포토로그


JSP 오류 - Access restriction: ~~ is not API(restriction on required library~~ by Kircheis

프로젝트를 새롭게 열고 jsp 파일을 하나 만들었는데...
메소드 하나 호출하려니까 빨간 줄이 보인다...

포커스에 마우스를 갖다가 대니 다음과 같이 나타난다.
뒤의 메시지까지 볼 것도 없이 이건 참조하는 library에서 해당 메소드를 지원하지 않기 때문이다.
아마도 JDK나 JRE를 별도 설치없이 이클립스에서 기본으로 설정되어 있는 경우에 해당하는 것 같다.
JRE 를 사용해서 그런다고 하는 분들도 계시지만, 내 경우에는 JDK 것을 사용했는데 문제였다.
문제야 뭐가 됐든 해결하려면 우선 프로젝트의 Properties를 열고, 왼쪽에서 Java BuildPath를 선택한다.
여기서 나타난 우측 화면의 Libraries 탭에서 JRE System Library라는 트리를 선택하고 우측에서 Edit를 선택하자.
아직 설정한 바가 없다면 Execution environment로 설정되어 있을 텐데, 이것을 가장 아래의 Workspace default JRE로 변경한다.
항목을 잘 보면 JRE 버전은 같은 것을 알 수 있다.
Finish를 눌려서 닫고 다시 jsp 파일을 확인해 보면 문제가 해결된 것을 알 수 있다.

덧글

댓글 입력 영역



메모장